Linux lietotāji, cita starpā, mudināja atjaunināt Flash Player ievainojamību dēļ

Linux lietotāji, cita starpā, mudināja atjaunināt Flash Player ievainojamību dēļ

Linux-Unix / Linux lietotāji, cita starpā, mudināja atjaunināt Flash Player ievainojamību dēļ 1 minūte lasīta

Adobe Systems

Lai gan Adobe Flash Player atjauninājumi ir vienādi ar kursu, kad runa ir par ikvienu, kurš kādu laiku ir izmantojis pārlūku, Adobe jaunākajā drošības biļetenā visiem lietotājiem ieteicams atjaunināt programmatūru ievainojamības dēļ. Tas ietver tos, kas darbojas ar GNU / Linux, kā arī Chrome OS, kas pats ir balstīts uz Gentoo. Viņi arī mudina tos, kas darbojas uz Unix balstītu macOS, atjaunināt Flash Player, kas var būt standarta procedūras rezultāts, lai gan ir interesanti atzīmēt, kādas ir ievainojamības.



Jaunākā programmatūras versija 30.0.0.113 novērš šādas kritiskās ievainojamības:



• CVE-2018-4945

• CVE-2018-5000



• CVE-2018-5001

• CVE-2018-5002

Lai gan ‘4945 ir sajaukšanas kļūda, kas ļauj patvaļīgi izpildīt kodu, un‘ 5002 attiecas uz bufera pārpildēm, ‘5000 un’ 5001 hipotētiski ir vairāk saistītas ar to, ka tie ļauj iespējami atklāt informāciju. Īpaši Linux drošības ekspertiem tas varētu šķist īpaši apgrūtinoši, jo tie, kas koncentrējas uz šo jomu, mēdz ļoti uzsvērt lietotāju informācijas privātumu.



Informācijas atklāšanas izmantošana ietver vesela skaitļa pārpildes problēmu un mēģinājumu nolasīt ārpus atmiņas esošās vietas. Abi šie izmantojumi tika atzīmēti tikai kā svarīgi, nevis kritiski jaunākajā Adobe Systems drošības biļetenā, taču, ja nekas cits, viņi noteikti saņems daudz pārklājuma GNU / Linux kopienā.

Visvairāk Adobe ir noraizējusies par ievainojamību ‘5002, jo tā jau ir izmantota dažos ierobežotos uzbrukumos, kuru mērķis ir Windows lietotāji. Šī ievainojamība izmanto Office dokumentu, lai lejupielādētu attālu failu lietotāja sistēmā un izmantotu Adobe Flash platformu.

Tā kā šāda veida uzbrukumi, šķiet, ir raksturīgi Windows platformai, tie, kas darbojas ar Linux kodolu balstītās operētājsistēmās, varētu likt pārējām ievainojamībām radīt vairāk bažas. Pašlaik nav bijušas ziņas par izmantošanu, kas ietekmētu atvērtā koda Office alternatīvas, kā arī nav saņemti ziņojumi par izmantošanu, kas radītu problēmas ikvienam, kam ir instalēts WINE lietojumprogrammu slānis, lai palaistu Windows programmatūru Linux. Tomēr viss, kas ļauj attālajam lietotājam lejupielādēt failu, drīzāk attiecas uz neatkarīgi no tā, kuru platformu lietotājs darbojas.

Tagi Linux drošība